{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2010-10008",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2010-10008",
    "idYear": 2010,
    "status": "PUBLISHED",
    "publishedAt": "2023-01-17T07:35:29.073Z",
    "updatedAt": "2024-11-25T16:35:21.618Z",
    "importedAt": "2026-10-24T01:55:28.403Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "simplesamlphp simplesamlphp-module-openidprovider trust.tpl.php cross site scripting",
      "summary": "** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in simplesamlphp simplesamlphp-module-openidprovider up to 0.8.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file templates/trust.tpl.php. The manipulation of the argument StateID leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The identifier of the patch is 8365d48c863cf06ccf1465cc0a161cefae29d69d. It is recommended to upgrade the affected component. The identifier VDB-218473 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.",
      "affected": [
        {
          "vendor": "simplesamlphp",
          "product": "simplesamlphp-module-openidprovider",
          "versions": [
            {
              "version": "0.1",
              "status": "affected"
            },
            {
              "version": "0.2",
              "status": "affected"
            },
            {
              "version": "0.3",
              "status": "affected"
            },
            {
              "version": "0.4",
              "status": "affected"
            },
            {
              "version": "0.5",
              "status": "affected"
            },
            {
              "version": "0.6",
              "status": "affected"
            },
            {
              "version": "0.7",
              "status": "affected"
            },
            {
              "version": "0.8",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}