{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2014-125098",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2014-125098",
    "idYear": 2014,
    "status": "PUBLISHED",
    "publishedAt": "2023-04-10T03:31:03.252Z",
    "updatedAt": "2025-02-07T19:37:14.998Z",
    "importedAt": "2026-10-24T01:55:40.400Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Dart http_server Directory Listing virtual_directory.dart VirtualDirectory cross site scripting",
      "summary": "A vulnerability was found in Dart http_server up to 0.9.5 and classified as problematic. Affected by this issue is the function VirtualDirectory of the file lib/src/virtual_directory.dart of the component Directory Listing Handler. The manipulation of the argument request.uri.path leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.9.6 is able to address this issue. The name of the patch is 27c1cbd8125bb0369e675eb72e48218496e48ffb. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225356.",
      "affected": [
        {
          "vendor": "Dart",
          "product": "http_server",
          "versions": [
            {
              "version": "0.9.0",
              "status": "affected"
            },
            {
              "version": "0.9.1",
              "status": "affected"
            },
            {
              "version": "0.9.2",
              "status": "affected"
            },
            {
              "version": "0.9.3",
              "status": "affected"
            },
            {
              "version": "0.9.4",
              "status": "affected"
            },
            {
              "version": "0.9.5",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}