{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2015-1006",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2015-1006",
    "idYear": 2015,
    "status": "PUBLISHED",
    "publishedAt": "2019-05-10T13:47:27.000Z",
    "updatedAt": "2024-08-06T04:26:11.549Z",
    "importedAt": "2026-10-24T01:55:44.251Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": null,
      "summary": "A vulnerable file in Opto 22 PAC Project Professional versions prior to R9.4006, PAC Project Basic versions prior to R9.4006, PAC Display Basic versions prior to R9.4f, PAC Display Professional versions prior to R9.4f, OptoOPCServer versions prior to R9.4c, and OptoDataLink version R9.4d and prior versions that were installed by PAC Project installer, versions prior to R9.4006, is susceptible to a heap-based buffer overflow condition that may allow remote code execution on the target system. Opto 22 suggests upgrading to the new product version as soon as possible.",
      "affected": [
        {
          "vendor": "Opto 22",
          "product": "PAC Project Professional",
          "versions": [
            {
              "version": "< R9.4006",
              "status": "affected"
            }
          ]
        },
        {
          "vendor": "Opto 22",
          "product": "PAC Project Basic",
          "versions": [
            {
              "version": "< R9.4006",
              "status": "affected"
            }
          ]
        },
        {
          "vendor": "Opto 22",
          "product": "PAC Display Basic",
          "versions": [
            {
              "version": "< R9.4f",
              "status": "affected"
            }
          ]
        },
        {
          "vendor": "Opto 22",
          "product": "PAC Display Professional",
          "versions": [
            {
              "version": "< R9.4f",
              "status": "affected"
            }
          ]
        },
        {
          "vendor": "Opto 22",
          "product": "OptoOPCServer",
          "versions": [
            {
              "version": "< R9.4c",
              "status": "affected"
            }
          ]
        },
        {
          "vendor": "Opto 22",
          "product": "OptoDataLink",
          "versions": [
            {
              "version": "R9.4d and prior that were installed by PAC Project installer",
              "status": "affected"
            },
            {
              "version": "versions prior to R9.4006",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}