{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2016-0781",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2016-0781",
    "idYear": 2016,
    "status": "PUBLISHED",
    "publishedAt": "2017-05-25T17:00:00.000Z",
    "updatedAt": "2024-08-05T22:30:04.905Z",
    "importedAt": "2026-10-24T01:55:48.151Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": null,
      "summary": "The UAA OAuth approval pages in Cloud Foundry v208 to v231, Login-server v1.6 to v1.14, UAA v2.0.0 to v2.7.4.1, UAA v3.0.0 to v3.2.0, UAA-Release v2 to v7 and Pivotal Elastic Runtime 1.6.x versions prior to 1.6.20 are vulnerable to an XSS attack by specifying malicious java script content in either the OAuth scopes (SCIM groups) or SCIM group descriptions.",
      "affected": [
        {
          "vendor": "Pivotal",
          "product": "Cloud Foundry",
          "versions": [
            {
              "version": "v208 to v231",
              "status": "affected"
            },
            {
              "version": "Login-server v1.6 to v1.14",
              "status": "affected"
            },
            {
              "version": "UAA v2.0.0 to v2.7.4.1",
              "status": "affected"
            },
            {
              "version": "UAA v3.0.0 to v3.2.0",
              "status": "affected"
            },
            {
              "version": "UAA-Release v2 to v7",
              "status": "affected"
            },
            {
              "version": "Elastic Runtime 1.6.x versions prior to 1.6.20",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}