{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2017-20158",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2017-20158",
    "idYear": 2017,
    "status": "PUBLISHED",
    "publishedAt": "2022-12-31T10:00:26.281Z",
    "updatedAt": "2024-08-05T21:45:25.988Z",
    "importedAt": "2026-10-24T01:55:56.138Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "vova07 Yii2 FileAPI Widget UploadAction.php run cross site scripting",
      "summary": "** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.",
      "affected": [
        {
          "vendor": "vova07",
          "product": "Yii2 FileAPI Widget",
          "versions": [
            {
              "version": "0.1.0",
              "status": "affected"
            },
            {
              "version": "0.1.1",
              "status": "affected"
            },
            {
              "version": "0.1.2",
              "status": "affected"
            },
            {
              "version": "0.1.3",
              "status": "affected"
            },
            {
              "version": "0.1.4",
              "status": "affected"
            },
            {
              "version": "0.1.5",
              "status": "affected"
            },
            {
              "version": "0.1.6",
              "status": "affected"
            },
            {
              "version": "0.1.7",
              "status": "affected"
            },
            {
              "version": "0.1.8",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}