{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2018-25055",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2018-25055",
    "idYear": 2018,
    "status": "PUBLISHED",
    "publishedAt": "2022-12-28T11:26:20.808Z",
    "updatedAt": "2024-08-05T12:26:39.671Z",
    "importedAt": "2026-10-24T01:56:00.349Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "FarCry Solr Pro Plugin Search solrProSearch.cfc cross site scripting",
      "summary": "A vulnerability was found in FarCry Solr Pro Plugin up to 1.5.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file packages/forms/solrProSearch.cfc of the component Search Handler. The manipulation of the argument suggestion leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is b8f3d61511c9b02b781ec442bfb803cbff8e08d5. It is recommended to upgrade the affected component. The identifier VDB-216961 was assigned to this vulnerability.",
      "affected": [
        {
          "vendor": "n/a",
          "product": "FarCry Solr Pro Plugin",
          "versions": [
            {
              "version": "1.0",
              "status": "affected"
            },
            {
              "version": "1.1",
              "status": "affected"
            },
            {
              "version": "1.2",
              "status": "affected"
            },
            {
              "version": "1.3",
              "status": "affected"
            },
            {
              "version": "1.4",
              "status": "affected"
            },
            {
              "version": "1.5",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}