{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2019-11287",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2019-11287",
    "idYear": 2019,
    "status": "PUBLISHED",
    "publishedAt": "2019-11-22T23:26:08.880Z",
    "updatedAt": "2024-09-16T22:24:51.121Z",
    "importedAt": "2026-10-24T01:56:04.670Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "RabbitMQ Web Management Plugin DoS via heap overflow",
      "summary": "Pivotal RabbitMQ, versions 3.7.x prior to 3.7.21 and 3.8.x prior to 3.8.1, and RabbitMQ for Pivotal Platform, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain a web management plugin that is vulnerable to a denial of service attack. The \"X-Reason\" HTTP Header can be leveraged to insert a malicious Erlang format string that will expand and consume the heap, resulting in the server crashing.",
      "affected": [
        {
          "vendor": "Pivotal",
          "product": "RabbitMQ for Pivotal Platform",
          "versions": [
            {
              "version": "1.16",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "1.16.7"
            },
            {
              "version": "1.17",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "1.17.4"
            }
          ]
        },
        {
          "vendor": "Pivotal",
          "product": "RabbitMQ",
          "versions": [
            {
              "version": "3.7",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "v3.7.21"
            },
            {
              "version": "3.8",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "v3.8.1"
            }
          ]
        }
      ]
    }
  }
}