{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2019-3396",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2019-3396",
    "idYear": 2019,
    "status": "PUBLISHED",
    "publishedAt": "2019-03-25T18:37:06.256Z",
    "updatedAt": "2025-10-21T23:45:41.385Z",
    "importedAt": "2026-10-24T01:56:12.831Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": null,
      "summary": "The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.",
      "affected": [
        {
          "vendor": "Atlassian",
          "product": "Confluence Server",
          "versions": [
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.6.12"
            },
            {
              "version": "6.7.0",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "unspecified"
            },
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.12.3"
            },
            {
              "version": "next of 6.13.0",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "unspecified"
            },
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.13.3"
            },
            {
              "version": "next of 6.14.0",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "unspecified"
            },
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.14.2"
            }
          ]
        }
      ]
    }
  }
}