{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2019-3398",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2019-3398",
    "idYear": 2019,
    "status": "PUBLISHED",
    "publishedAt": "2019-04-18T17:21:37.687Z",
    "updatedAt": "2025-10-21T23:45:39.283Z",
    "importedAt": "2026-10-24T01:56:12.831Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": null,
      "summary": "Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource. A remote attacker who has permission to add attachments to pages and / or blogs or to create a new space or a personal space or who has 'Admin' permissions for a space can exploit this path traversal vulnerability to write files to arbitrary locations which can lead to remote code execution on systems that run a vulnerable version of Confluence Server or Data Center. All versions of Confluence Server from 2.0.0 before 6.6.13 (the fixed version for 6.6.x), from 6.7.0 before 6.12.4 (the fixed version for 6.12.x), from 6.13.0 before 6.13.4 (the fixed version for 6.13.x), from 6.14.0 before 6.14.3 (the fixed version for 6.14.x), and from 6.15.0 before 6.15.2 are affected by this vulnerability.",
      "affected": [
        {
          "vendor": "Atlassian",
          "product": "Confluence",
          "versions": [
            {
              "version": "2.0.0",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "unspecified"
            },
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.6.13"
            },
            {
              "version": "6.7.0",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "unspecified"
            },
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.12.4"
            },
            {
              "version": "6.13.0",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "unspecified"
            },
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.13.4"
            },
            {
              "version": "6.14.0",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "unspecified"
            },
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.14.3"
            },
            {
              "version": "6.15.0",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "unspecified"
            },
            {
              "version": "unspecified",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "6.15.2"
            }
          ]
        }
      ]
    }
  }
}