{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2019-9497",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2019-9497",
    "idYear": 2019,
    "status": "PUBLISHED",
    "publishedAt": "2019-04-17T13:31:08.000Z",
    "updatedAt": "2024-08-04T21:54:44.151Z",
    "importedAt": "2026-10-24T01:56:12.831Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "The implementations of EAP-PWD in hostapd EAP Server and wpa_supplicant EAP Peer do not validate the scalar and element values in EAP-pwd-Commit",
      "summary": "The implementations of EAP-PWD in hostapd EAP Server and wpa_supplicant EAP Peer do not validate the scalar and element values in EAP-pwd-Commit. This vulnerability may allow an attacker to complete EAP-PWD authentication without knowing the password. However, unless the crypto library does not implement additional checks for the EC point, the attacker will not be able to derive the session key or complete the key exchange. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.4 are affected. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.",
      "affected": [
        {
          "vendor": "Wi-Fi Alliance",
          "product": "hostapd with EAP-pwd support",
          "versions": [
            {
              "version": "2.7",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.7"
            }
          ]
        },
        {
          "vendor": "Wi-Fi Alliance",
          "product": "wpa_supplicant with EAP-pwd support",
          "versions": [
            {
              "version": "2.7",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.7"
            }
          ]
        },
        {
          "vendor": "Wi-Fi Alliance",
          "product": "hostapd with SAE support",
          "versions": [
            {
              "version": "2.4",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.4"
            }
          ]
        },
        {
          "vendor": "Wi-Fi Alliance",
          "product": "wpa_supplicant with SAE support",
          "versions": [
            {
              "version": "2.4",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.4"
            }
          ]
        }
      ]
    }
  }
}