{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2020-1746",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2020-1746",
    "idYear": 2020,
    "status": "PUBLISHED",
    "publishedAt": "2020-05-12T17:30:47.000Z",
    "updatedAt": "2024-08-04T06:46:31.070Z",
    "importedAt": "2026-10-24T01:56:17.081Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": null,
      "summary": "A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when the ldap_attr and ldap_entry community modules are used. The issue discloses the LDAP bind password to stdout or a log file if a playbook task is written using the bind_pw in the parameters field. The highest threat from this vulnerability is data confidentiality.",
      "affected": [
        {
          "vendor": "Red Hat",
          "product": "ansible",
          "versions": [
            {
              "version": "ansible-engine versions 2.7.x before 2.7.17",
              "status": "affected"
            },
            {
              "version": "ansible-engine versions 2.8.x before 2.8.11",
              "status": "affected"
            },
            {
              "version": "ansible-engine versions 2.9.x before 2.9.7",
              "status": "affected"
            },
            {
              "version": "Ansible Tower <= 3.4.5",
              "status": "affected"
            },
            {
              "version": "Ansible Tower <= 3.5.5",
              "status": "affected"
            },
            {
              "version": "Ansible Tower <= 3.6.3",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}