CVE-2020-26216
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2020
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
Cross-Site Scripting in TYPO3 Fluid
TYPO3 Fluid before versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 and 2.6.10 is vulnerable to Cross-Site Scripting. Three XSS vulnerabilities have been detected in Fluid: 1. TagBasedViewHelper allowed XSS through maliciously crafted additionalAttributes arrays by creating keys with attribute-closing quotes followed by HTML. When rendering such attributes, TagBuilder would not escape the keys. 2. ViewHelpers which used the CompileWithContentArgumentAndRenderStatic trait, and which declared escapeOutput = false, would receive the content argument in unescaped format. 3. Subclasses of AbstractConditionViewHelper would receive the then and else arguments in unescaped format. Update to versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 or 2.6.10 of this typo3fluid/fluid package that fix the problem described. More details are available in the linked advisory.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
Fluid
- Vendor
- TYPO3
- Product
- Fluid
- Platforms
- Unknown
- Default status
Unknown
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| >= 2.0.0, < 2.0.8 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 2.1.0, < 2.1.7 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 2.2.0, < 2.2.4 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 2.3.0, < 2.3.7 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 2.4.0, < 2.4.4 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 2.5.0, < 2.5.11 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 2.6.0, < 2.6.10 | affected | Unavailable | Unavailable | Unavailable | None listed |