{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2020-4051",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2020-4051",
    "idYear": 2020,
    "status": "PUBLISHED",
    "publishedAt": "2020-06-15T00:00:00.000Z",
    "updatedAt": "2024-08-04T07:52:20.806Z",
    "importedAt": "2026-10-24T01:56:21.187Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "XSS in Dijit Editor's LinkDialog plugin",
      "summary": "In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.",
      "affected": [
        {
          "vendor": "Dojo",
          "product": "dijit",
          "versions": [
            {
              "version": "< 1.11.11",
              "status": "affected"
            },
            {
              "version": ">= 1.12.0, < 1.12.9",
              "status": "affected"
            },
            {
              "version": ">= 1.13.0, < 1.13.8",
              "status": "affected"
            },
            {
              "version": ">= 1.14.0, < 1.14.7",
              "status": "affected"
            },
            {
              "version": ">= 1.15.0, < 1.15.4",
              "status": "affected"
            },
            {
              "version": ">= 1.16.0, < 1.16.3",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}