{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2020-8835",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2020-8835",
    "idYear": 2020,
    "status": "PUBLISHED",
    "publishedAt": "2020-04-02T18:00:23.885Z",
    "updatedAt": "2024-09-17T02:15:48.820Z",
    "importedAt": "2026-10-24T01:56:21.187Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Linux kernel bpf verifier vulnerability",
      "summary": "In the Linux kernel 5.5.0 and newer, the bpf verifier (kernel/bpf/verifier.c) did not properly restrict the register bounds for 32-bit operations, leading to out-of-bounds reads and writes in kernel memory. The vulnerability also affects the Linux 5.4 stable series, starting with v5.4.7, as the introducing commit was backported to that branch. This vulnerability was fixed in 5.6.1, 5.5.14, and 5.4.29. (issue is aka ZDI-CAN-10780)",
      "affected": [
        {
          "vendor": "Linux kernel",
          "product": "Linux kernel",
          "versions": [
            {
              "version": "5.6-stable",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "5.6.1"
            },
            {
              "version": "5.5-stable",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "5.5.14"
            },
            {
              "version": "5.4.7",
              "status": "affected",
              "versionType": "custom",
              "lessThan": "5.4-stable*",
              "changes": [
                {
                  "at": "5.4.29",
                  "status": "unaffected"
                }
              ]
            }
          ]
        }
      ]
    }
  }
}