{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2021-38153",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2021-38153",
    "idYear": 2021,
    "status": "PUBLISHED",
    "publishedAt": "2021-09-22T09:05:11.000Z",
    "updatedAt": "2024-08-04T01:37:15.929Z",
    "importedAt": "2026-10-24T01:56:32.228Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Timing Attack Vulnerability for Apache Kafka Connect and Clients",
      "summary": "Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.",
      "affected": [
        {
          "vendor": "Apache Software Foundation",
          "product": "Apache Kafka",
          "versions": [
            {
              "version": "Apache Kafka 2.0.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.0.1"
            },
            {
              "version": "Apache Kafka 2.1.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.1.1"
            },
            {
              "version": "Apache Kafka 2.2.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.2.2"
            },
            {
              "version": "Apache Kafka 2.3.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.3.1"
            },
            {
              "version": "Apache Kafka 2.4.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.4.1"
            },
            {
              "version": "Apache Kafka 2.5.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.5.1"
            },
            {
              "version": "Apache Kafka 2.6.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.6.2"
            },
            {
              "version": "Apache Kafka 2.7.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.7.1"
            },
            {
              "version": "Apache Kafka 2.8.x",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.8.0"
            }
          ]
        }
      ]
    }
  }
}