{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2021-4231",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2021-4231",
    "idYear": 2021,
    "status": "PUBLISHED",
    "publishedAt": "2022-05-26T07:10:14.000Z",
    "updatedAt": "2025-04-15T14:38:13.128Z",
    "importedAt": "2026-10-24T01:56:36.661Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Angular Comment cross site scripting",
      "summary": "A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.",
      "affected": [
        {
          "vendor": "unspecified",
          "product": "Angular",
          "versions": [
            {
              "version": "11.0.0",
              "status": "affected"
            },
            {
              "version": "11.0.1",
              "status": "affected"
            },
            {
              "version": "11.0.2",
              "status": "affected"
            },
            {
              "version": "11.0.3",
              "status": "affected"
            },
            {
              "version": "11.0.4",
              "status": "affected"
            },
            {
              "version": "11.1.0-next.0",
              "status": "affected"
            },
            {
              "version": "11.1.0-next.1",
              "status": "affected"
            },
            {
              "version": "11.1.0-next.2",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}