{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2022-25770",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2022-25770",
    "idYear": 2022,
    "status": "PUBLISHED",
    "publishedAt": "2024-09-18T21:26:34.059Z",
    "updatedAt": "2024-09-19T14:47:14.786Z",
    "importedAt": "2026-10-24T01:56:40.826Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Insufficient authentication in upgrade flow",
      "summary": "Mautic allows you to update the application via an upgrade script.\n\nThe upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.\n\nThis vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.",
      "affected": [
        {
          "vendor": "Mautic",
          "product": "Mautic",
          "packageName": "mautic/core-lib",
          "collectionURL": "https://packagist.org",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": ">= 1.0.0-beta3",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "< 4.4.13"
            },
            {
              "version": ">= 5.0.0",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "< 5.1.1."
            }
          ]
        }
      ]
    }
  }
}