{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2022-29187",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2022-29187",
    "idYear": 2022,
    "status": "PUBLISHED",
    "publishedAt": "2022-07-12T00:00:00.000Z",
    "updatedAt": "2024-08-03T06:17:54.233Z",
    "importedAt": "2026-10-24T01:56:40.826Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Bypass of safe.directory protections in Git",
      "summary": "Git is a distributed revision control system. Git prior to versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5, is vulnerable to privilege escalation in all platforms. An unsuspecting user could still be affected by the issue reported in CVE-2022-24765, for example when navigating as root into a shared tmp directory that is owned by them, but where an attacker could create a git repository. Versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5 contain a patch for this issue. The simplest way to avoid being affected by the exploit described in the example is to avoid running git as root (or an Administrator in Windows), and if needed to reduce its use to a minimum. While a generic workaround is not possible, a system could be hardened from the exploit described in the example by removing any such repository if it exists already and creating one as root to block any future attacks.",
      "affected": [
        {
          "vendor": "git",
          "product": "git",
          "versions": [
            {
              "version": ">= 2.30.3, < 2.30.5",
              "status": "affected"
            },
            {
              "version": ">= 2.31.2, < 2.31.4",
              "status": "affected"
            },
            {
              "version": ">= 2.32.1, < 2.32.3",
              "status": "affected"
            },
            {
              "version": ">= 2.33.2, < 2.33.4",
              "status": "affected"
            },
            {
              "version": ">= 2.34.2, < 2.34.4",
              "status": "affected"
            },
            {
              "version": ">= 2.35.2, < 2.35.4",
              "status": "affected"
            },
            {
              "version": ">= 2.36, < 2.36.2",
              "status": "affected"
            },
            {
              "version": ">= 2.37, < 2.37.1",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}