cveboard RSS feed

CVE-2022-39361

CVE.org · Published

Historical CVEsJSONAI instructions

Record status
Published
Identifier year (not publication year)
2022
Source publication
Source updated
Imported by cveboard
Source snapshot
cve_2026-10-24_midnight_baseline ·

Plain text

CNA source text (English)

Metabase vulnerable to Remote Code Execution via H2

Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, H2 (Sample Database) could allow Remote Code Execution (RCE), which can be abused by users able to write SQL queries on H2 databases. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer allows DDL statements in H2 native queries.

Scoped product and version facts

Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.

Exploitation unknown; this catalogue does not assess exploitation.

metabase

Vendor
metabase
Product
metabase
Platforms
Unknown
Default status
Unknown
metabase · Scoped product and version facts
Version (version)Status (status)Version scheme (versionType)Exclusive end (lessThan)Inclusive end (lessThanOrEqual)Status changes (at → status)
< 0.41.9affectedUnavailableUnavailableUnavailableNone listed
>= 0.42.0, < 0.42.6affectedUnavailableUnavailableUnavailableNone listed
>= 0.43.0, < 0.43.7affectedUnavailableUnavailableUnavailableNone listed
>= 0.44.0, < 0.44.5affectedUnavailableUnavailableUnavailableNone listed
>= 1.0.0, < 1.41.9affectedUnavailableUnavailableUnavailableNone listed
>= 1.42.0, < 1.42.6affectedUnavailableUnavailableUnavailableNone listed
>= 1.43.0, < 1.43.7affectedUnavailableUnavailableUnavailableNone listed
>= 1.44.0, < 1.44.5affectedUnavailableUnavailableUnavailableNone listed