{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2022-4364",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2022-4364",
    "idYear": 2022,
    "status": "PUBLISHED",
    "publishedAt": "2022-12-08T00:00:00.000Z",
    "updatedAt": "2025-10-15T13:18:53.461Z",
    "importedAt": "2026-10-24T01:56:49.724Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Teledyne FLIR AX8 Web Service palette.php command injection",
      "summary": "A vulnerability has been found in Teledyne FLIR AX8 up to 1.46.16. Affected by this issue is some unknown functionality of the file palette.php of the component Web Service Handler. The manipulation of the argument palette leads to command injection. The attack is possible to be carried out remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.49.16 can resolve this issue. Upgrading the affected component is advised. The vendor points out: \"FLIR AX8 internal web site has been refactored to be able to handle the reported vulnerabilities.\"",
      "affected": [
        {
          "vendor": "Teledyne FLIR",
          "product": "AX8",
          "versions": [
            {
              "version": "1.46.0",
              "status": "affected"
            },
            {
              "version": "1.46.1",
              "status": "affected"
            },
            {
              "version": "1.46.2",
              "status": "affected"
            },
            {
              "version": "1.46.3",
              "status": "affected"
            },
            {
              "version": "1.46.4",
              "status": "affected"
            },
            {
              "version": "1.46.5",
              "status": "affected"
            },
            {
              "version": "1.46.6",
              "status": "affected"
            },
            {
              "version": "1.46.7",
              "status": "affected"
            },
            {
              "version": "1.46.8",
              "status": "affected"
            },
            {
              "version": "1.46.9",
              "status": "affected"
            },
            {
              "version": "1.46.10",
              "status": "affected"
            },
            {
              "version": "1.46.11",
              "status": "affected"
            },
            {
              "version": "1.46.12",
              "status": "affected"
            },
            {
              "version": "1.46.13",
              "status": "affected"
            },
            {
              "version": "1.46.14",
              "status": "affected"
            },
            {
              "version": "1.46.15",
              "status": "affected"
            },
            {
              "version": "1.46.16",
              "status": "affected"
            },
            {
              "version": "1.49.16",
              "status": "unaffected"
            }
          ]
        }
      ]
    }
  }
}