{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2022-4582",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2022-4582",
    "idYear": 2022,
    "status": "PUBLISHED",
    "publishedAt": "2022-12-17T00:00:00.000Z",
    "updatedAt": "2025-04-15T13:01:22.373Z",
    "importedAt": "2026-10-24T01:56:49.724Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "starter-public-edition-4 cross site scripting",
      "summary": "A vulnerability was found in starter-public-edition-4 up to 4.6.10. It has been classified as problematic. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.6.11 is able to address this issue. The name of the patch is 2606983c20f6ea3430ac4b36b3d2e88aafef45da. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216168.",
      "affected": [
        {
          "vendor": "unspecified",
          "product": "starter-public-edition-4",
          "versions": [
            {
              "version": "4.6.0",
              "status": "affected"
            },
            {
              "version": "4.6.1",
              "status": "affected"
            },
            {
              "version": "4.6.2",
              "status": "affected"
            },
            {
              "version": "4.6.3",
              "status": "affected"
            },
            {
              "version": "4.6.4",
              "status": "affected"
            },
            {
              "version": "4.6.5",
              "status": "affected"
            },
            {
              "version": "4.6.6",
              "status": "affected"
            },
            {
              "version": "4.6.7",
              "status": "affected"
            },
            {
              "version": "4.6.8",
              "status": "affected"
            },
            {
              "version": "4.6.9",
              "status": "affected"
            },
            {
              "version": "4.6.10",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}