{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2023-0867",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2023-0867",
    "idYear": 2023,
    "status": "PUBLISHED",
    "publishedAt": "2023-02-23T14:49:30.832Z",
    "updatedAt": "2024-08-02T05:24:34.746Z",
    "importedAt": "2026-10-24T01:56:49.724Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Multiple stored and reflected Cross-site Scripting in webapp",
      "summary": "Multiple stored and reflected cross-site scripting vulnerabilities in webapp jsp pages in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to confidential session information. Users\nshould upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and\nHorizon installation instructions state that they are intended for installation\nwithin an organization's private networks and should not be directly accessible\nfrom the Internet.\n\n\n\n\n\n\n\n",
      "affected": [
        {
          "vendor": "The OpenNMS Group",
          "product": "Meridian",
          "platforms": [
            "Windows",
            "Linux",
            "MacOS"
          ],
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "2020.1.0",
              "status": "affected",
              "versionType": "git",
              "lessThan": "2020.1.32"
            },
            {
              "version": "2021.1.0",
              "status": "affected",
              "versionType": "git",
              "lessThan": "2021.1.24"
            },
            {
              "version": "2022.1.0",
              "status": "affected",
              "versionType": "git",
              "lessThan": "2022.1.13"
            },
            {
              "version": "2023.1.0",
              "status": "unaffected"
            }
          ]
        },
        {
          "vendor": "The OpenNMS Group",
          "product": "Horizon",
          "platforms": [
            "Windows",
            "Linux",
            "MacOS"
          ],
          "defaultStatus": "affected",
          "versions": [
            {
              "version": "26.0.0",
              "status": "affected",
              "versionType": "git",
              "lessThan": "31.0.4"
            }
          ]
        }
      ]
    }
  }
}