{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2023-37470",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2023-37470",
    "idYear": 2023,
    "status": "PUBLISHED",
    "publishedAt": "2023-08-04T15:12:43.188Z",
    "updatedAt": "2024-10-17T14:54:36.299Z",
    "importedAt": "2026-10-24T01:56:53.804Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint ",
      "summary": "Metabase is an open-source business intelligence and analytics platform. Prior to versions 0.43.7.3, 0.44.7.3, 0.45.4.3, 0.46.6.4, 1.43.7.3, 1.44.7.3, 1.45.4.3, and 1.46.6.4, a vulnerability could potentially allow remote code execution on one's Metabase server. The core issue is that one of the supported data warehouses (an embedded in-memory database H2), exposes a number of ways for a connection string to include code that is then executed by the process running the embedded database. Because Metabase allows users to connect to databases, this means that a user supplied string can be used to inject executable code. Metabase allows users to validate their connection string before adding a database (including on setup), and this validation API was the primary vector used as it can be called without validation. Versions 0.43.7.3, 0.44.7.3, 0.45.4.3, 0.46.6.4, 1.43.7.3, 1.44.7.3, 1.45.4.3, and 1.46.6.4 fix this issue by removing the ability of users to add H2 databases entirely. As a workaround, it is possible to block these vulnerabilities at the network level by blocking the endpoints `POST /api/database`, `PUT /api/database/:id`, and `POST /api/setup/validateuntil`. Those who use H2 as a file-based database should migrate to SQLite.",
      "affected": [
        {
          "vendor": "metabase",
          "product": "metabase",
          "versions": [
            {
              "version": "< 0.43.7.3",
              "status": "affected"
            },
            {
              "version": ">= 0.44.0.0, < 0.44.7.3",
              "status": "affected"
            },
            {
              "version": ">= 0.45.0.0, < 0.45.4.3",
              "status": "affected"
            },
            {
              "version": ">= 0.46.0.0, < 0.46.6.4",
              "status": "affected"
            },
            {
              "version": ">= 1.0.0, < 1.43.7.3",
              "status": "affected"
            },
            {
              "version": ">= 1.44.0.0, < 1.44.7.3",
              "status": "affected"
            },
            {
              "version": ">= 1.45.0.0, < 1.45.4.3",
              "status": "affected"
            },
            {
              "version": ">= 1.46.0.0, < 1.46.6.4",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}