{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2023-47248",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2023-47248",
    "idYear": 2023,
    "status": "PUBLISHED",
    "publishedAt": "2023-11-09T08:17:08.431Z",
    "updatedAt": "2025-02-13T17:17:56.649Z",
    "importedAt": "2026-10-24T01:56:58.683Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "PyArrow, PyArrow: Arbitrary code execution when loading a malicious data file",
      "summary": "Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).\n\nThis vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.\n\nIt is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.\n\nIf it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See  https://pypi.org/project/pyarrow-hotfix/  for instructions.",
      "affected": [
        {
          "vendor": "Apache Software Foundation",
          "product": "PyArrow",
          "packageName": "pyarrow",
          "collectionURL": "https://pypi.org/",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "0.14.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "14.0.0"
            }
          ]
        },
        {
          "vendor": "Apache Software Foundation",
          "product": "PyArrow",
          "packageName": "pyarrow",
          "collectionURL": "https://conda-forge.org/",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "0.14.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "14.0.0"
            }
          ]
        }
      ]
    }
  }
}