{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-10007",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-10007",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2024-11-07T20:58:17.777Z",
    "updatedAt": "2024-11-08T15:50:55.912Z",
    "importedAt": "2026-10-24T01:57:03.413Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Pre-Receive Hook Path Collision Vulnerability in GitHub Enterprise Server Allowing Privilege Escalation",
      "summary": "A path collision and arbitrary code execution vulnerability was identified in GitHub Enterprise Server that allowed container escape to escalate to root via ghe-firejail path. Exploitation of this vulnerability requires Enterprise Administrator access to the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise prior to 3.15 and was fixed in versions 3.14.3, 3.13.6, 3.12.11, and 3.11.17. This vulnerability was reported via the GitHub Bug Bounty program.",
      "affected": [
        {
          "vendor": "GitHub",
          "product": "Enterprise Server",
          "defaultStatus": "affected",
          "versions": [
            {
              "version": "3.11.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "3.11.16",
              "changes": [
                {
                  "at": "3.11.17",
                  "status": "unaffected"
                }
              ]
            },
            {
              "version": "3.12.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "3.12.10",
              "changes": [
                {
                  "at": "3.12.11",
                  "status": "unaffected"
                }
              ]
            },
            {
              "version": "3.13.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "3.13.5",
              "changes": [
                {
                  "at": "3.13.6",
                  "status": "unaffected"
                }
              ]
            },
            {
              "version": "3.14.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "3.14.2",
              "changes": [
                {
                  "at": "3.14.3",
                  "status": "unaffected"
                }
              ]
            }
          ]
        }
      ]
    }
  }
}