{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-10977",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-10977",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2024-11-14T13:00:05.715Z",
    "updatedAt": "2025-11-03T21:51:38.414Z",
    "importedAt": "2026-10-24T01:57:03.413Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "PostgreSQL libpq retains an error message from man-in-the-middle",
      "summary": "Client use of server error message in PostgreSQL allows a server not trusted under current SSL or GSS settings to furnish arbitrary non-NUL bytes to the libpq application.  For example, a man-in-the-middle attacker could send a long error message that a human or screen-scraper user of psql mistakes for valid query results.  This is probably not a concern for clients where the user interface unambiguously indicates the boundary between one error message and other text.  Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.",
      "affected": [
        {
          "vendor": "n/a",
          "product": "PostgreSQL",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "17",
              "status": "affected",
              "versionType": "rpm",
              "lessThan": "17.1"
            },
            {
              "version": "16",
              "status": "affected",
              "versionType": "rpm",
              "lessThan": "16.5"
            },
            {
              "version": "15",
              "status": "affected",
              "versionType": "rpm",
              "lessThan": "15.9"
            },
            {
              "version": "14",
              "status": "affected",
              "versionType": "rpm",
              "lessThan": "14.14"
            },
            {
              "version": "13",
              "status": "affected",
              "versionType": "rpm",
              "lessThan": "13.17"
            },
            {
              "version": "0",
              "status": "affected",
              "versionType": "rpm",
              "lessThan": "12.21"
            }
          ]
        }
      ]
    }
  }
}