{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-13903",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-13903",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2025-03-21T07:00:14.647Z",
    "updatedAt": "2025-03-21T12:31:02.832Z",
    "importedAt": "2026-10-24T01:57:07.518Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "quickjs-ng QuickJS qjs quickjs.c JS_GetRuntime stack-based overflow",
      "summary": "A vulnerability was found in quickjs-ng QuickJS up to 0.8.0. It has been declared as problematic. Affected by this vulnerability is the function JS_GetRuntime of the file quickjs.c of the component qjs. The manipulation leads to stack-based buffer overflow. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The patch is named 99c02eb45170775a9a679c32b45dd4000ea67aff. It is recommended to upgrade the affected component.",
      "affected": [
        {
          "vendor": "quickjs-ng",
          "product": "QuickJS",
          "versions": [
            {
              "version": "0.1",
              "status": "affected"
            },
            {
              "version": "0.2",
              "status": "affected"
            },
            {
              "version": "0.3",
              "status": "affected"
            },
            {
              "version": "0.4",
              "status": "affected"
            },
            {
              "version": "0.5",
              "status": "affected"
            },
            {
              "version": "0.6",
              "status": "affected"
            },
            {
              "version": "0.7",
              "status": "affected"
            },
            {
              "version": "0.8",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}