{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-21537",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-21537",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2024-10-31T05:00:03.948Z",
    "updatedAt": "2026-08-17T15:25:17.480Z",
    "importedAt": "2026-10-24T01:57:07.518Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": null,
      "summary": "Versions of the package lilconfig from 3.1.0 and before 3.1.1 are vulnerable to Arbitrary Code Execution due to the insecure usage of eval in the dynamicImport function. An attacker can exploit this vulnerability by passing a malicious input through the defaultLoaders function.",
      "affected": [
        {
          "vendor": "n/a",
          "product": "lilconfig",
          "versions": [
            {
              "version": "3.1.0",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "3.1.1"
            }
          ]
        },
        {
          "vendor": "n/a",
          "product": "org.webjars.npm:lilconfig",
          "versions": [
            {
              "version": "3.1.0",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "3.1.1"
            }
          ]
        }
      ]
    }
  }
}