{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-21672",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-21672",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2024-01-16T05:00:00.703Z",
    "updatedAt": "2025-06-02T15:12:12.778Z",
    "importedAt": "2026-10-24T01:57:07.518Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": null,
      "summary": "This High severity Remote Code Execution (RCE) vulnerability was introduced in version 2.1.0 of Confluence Data Center and Server.\n\nRemote Code Execution (RCE) vulnerability, with a CVSS Score of 8.3 and a CVSS Vector of CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H allows an unauthenticated attacker to remotely expose assets in your environment susceptible to exploitation which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires user interaction.\n\nAtlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions:\n\n* Confluence Data Center and Server 7.19: Upgrade to a release 7.19.18, or any higher 7.19.x release\n* Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release\n* Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release\n\nSee the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives).",
      "affected": [
        {
          "vendor": "Atlassian",
          "product": "Confluence Data Center",
          "versions": [
            {
              "version": "< 7.19.0",
              "status": "unaffected"
            },
            {
              "version": ">= 7.19.0",
              "status": "affected"
            },
            {
              "version": ">= 8.0.0",
              "status": "affected"
            },
            {
              "version": ">= 8.1.0",
              "status": "affected"
            },
            {
              "version": ">= 8.2.0",
              "status": "affected"
            },
            {
              "version": ">= 8.3.0",
              "status": "affected"
            },
            {
              "version": ">= 8.4.0",
              "status": "affected"
            },
            {
              "version": ">= 8.5.0",
              "status": "affected"
            },
            {
              "version": ">= 8.6.0",
              "status": "affected"
            },
            {
              "version": ">= 8.7.1",
              "status": "affected"
            },
            {
              "version": ">= 7.19.18",
              "status": "unaffected"
            },
            {
              "version": ">= 8.5.5",
              "status": "unaffected"
            },
            {
              "version": ">= 8.7.2",
              "status": "unaffected"
            }
          ]
        },
        {
          "vendor": "Atlassian",
          "product": "Confluence Server",
          "versions": [
            {
              "version": "< 7.19.0",
              "status": "unaffected"
            },
            {
              "version": ">= 7.19.0",
              "status": "affected"
            },
            {
              "version": ">= 8.0.0",
              "status": "affected"
            },
            {
              "version": ">= 8.1.0",
              "status": "affected"
            },
            {
              "version": ">= 8.2.0",
              "status": "affected"
            },
            {
              "version": ">= 8.3.0",
              "status": "affected"
            },
            {
              "version": ">= 8.4.0",
              "status": "affected"
            },
            {
              "version": ">= 8.5.0",
              "status": "affected"
            },
            {
              "version": ">= 8.6.0",
              "status": "affected"
            },
            {
              "version": ">= 8.7.1",
              "status": "affected"
            },
            {
              "version": ">= 7.19.18",
              "status": "unaffected"
            },
            {
              "version": ">= 8.5.5",
              "status": "unaffected"
            }
          ]
        }
      ]
    }
  }
}