{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-22371",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-22371",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2024-02-26T09:22:38.384Z",
    "updatedAt": "2024-10-31T13:03:53.000Z",
    "importedAt": "2026-10-24T01:57:07.518Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Apache Camel issue on ExchangeCreatedEvent",
      "summary": "Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0.\n\nUsers are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.\n\n",
      "affected": [
        {
          "vendor": "Apache Software Foundation",
          "product": "Apache Camel",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "1.x",
              "status": "unaffected",
              "versionType": "semver",
              "lessThanOrEqual": "1.6.0"
            },
            {
              "version": "3.21.x",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "3.21.3"
            },
            {
              "version": "3.22.x",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "3.22.0"
            },
            {
              "version": "4.0.x",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "4.0.3"
            },
            {
              "version": "4.x",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "4.3.0"
            }
          ]
        }
      ]
    }
  }
}