{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-27135",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-27135",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2024-03-12T18:18:06.720Z",
    "updatedAt": "2025-02-13T17:41:17.703Z",
    "importedAt": "2026-10-24T01:57:07.518Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution",
      "summary": "Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with \"functionsWorkerEnabled=true\".\n\nThis issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. \n\n2.10 Pulsar Function Worker users should upgrade to at least 2.10.6.\n2.11 Pulsar Function Worker users should upgrade to at least 2.11.4.\n3.0 Pulsar Function Worker users should upgrade to at least 3.0.3.\n3.1 Pulsar Function Worker users should upgrade to at least 3.1.3.\n3.2 Pulsar Function Worker users should upgrade to at least 3.2.1.\n\nUsers operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.",
      "affected": [
        {
          "vendor": "Apache Software Foundation",
          "product": "Apache Pulsar",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "2.4.0",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "2.10.6"
            },
            {
              "version": "2.11.0",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "2.11.4"
            },
            {
              "version": "3.0.0",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "3.0.3"
            },
            {
              "version": "3.1.0",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "3.1.3"
            },
            {
              "version": "3.2.0",
              "status": "affected",
              "versionType": "semver",
              "lessThan": "3.2.1"
            }
          ]
        }
      ]
    }
  }
}