{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-3081",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-3081",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2024-03-29T14:31:05.512Z",
    "updatedAt": "2024-08-15T15:45:10.663Z",
    "importedAt": "2026-10-24T01:57:16.009Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "EasyCorp EasyAdmin Autocomplete autocomplete.js cross site scripting",
      "summary": "A vulnerability was found in EasyCorp EasyAdmin up to 4.8.9. It has been declared as problematic. Affected by this vulnerability is the function Autocomplete of the file assets/js/autocomplete.js of the component Autocomplete. The manipulation of the argument item leads to cross site scripting. The attack can be launched remotely. Upgrading to version 4.8.10 is able to address this issue. The identifier of the patch is 127436e4c3f56276d548070f99e61b7234200a11. It is recommended to upgrade the affected component. The identifier VDB-258613 was assigned to this vulnerability.",
      "affected": [
        {
          "vendor": "EasyCorp",
          "product": "EasyAdmin",
          "versions": [
            {
              "version": "4.8.0",
              "status": "affected"
            },
            {
              "version": "4.8.1",
              "status": "affected"
            },
            {
              "version": "4.8.2",
              "status": "affected"
            },
            {
              "version": "4.8.3",
              "status": "affected"
            },
            {
              "version": "4.8.4",
              "status": "affected"
            },
            {
              "version": "4.8.5",
              "status": "affected"
            },
            {
              "version": "4.8.6",
              "status": "affected"
            },
            {
              "version": "4.8.7",
              "status": "affected"
            },
            {
              "version": "4.8.8",
              "status": "affected"
            },
            {
              "version": "4.8.9",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}