cveboard RSS feed

CVE-2024-32465

CVE.org · Published

Historical CVEsJSONAI instructions

Record status
Published
Identifier year (not publication year)
2024
Source publication
Source updated
Imported by cveboard
Source snapshot
cve_2026-10-24_midnight_baseline ·

Plain text

CNA source text (English)

Git's protections for cloning untrusted repositories can be bypassed

Git is a revision control system. The Git project recommends to avoid working in untrusted repositories, and instead to clone it first with `git clone --no-local` to obtain a clean copy. Git has specific protections to make that a safe operation even with an untrusted source repository, but vulnerabilities allow those protections to be bypassed. In the context of cloning local repositories owned by other users, this vulnerability has been covered in CVE-2024-32004. But there are circumstances where the fixes for CVE-2024-32004 are not enough: For example, when obtaining a `.zip` file containing a full copy of a Git repository, it should not be trusted by default to be safe, as e.g. hooks could be configured to run within the context of that repository. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid using Git in repositories that have been obtained via archives from untrusted sources.

Scoped product and version facts

Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.

Exploitation unknown; this catalogue does not assess exploitation.

git

Vendor
git
Product
git
Platforms
Unknown
Default status
Unknown
git · Scoped product and version facts
Version (version)Status (status)Version scheme (versionType)Exclusive end (lessThan)Inclusive end (lessThanOrEqual)Status changes (at → status)
= 2.45.0affectedUnavailableUnavailableUnavailableNone listed
= 2.44.0affectedUnavailableUnavailableUnavailableNone listed
>= 2.43.0, < 2.43.4affectedUnavailableUnavailableUnavailableNone listed
>= 2.42.0, < 2.42.2affectedUnavailableUnavailableUnavailableNone listed
= 2.41.0affectedUnavailableUnavailableUnavailableNone listed
>= 2.40.0, < 2.40.2affectedUnavailableUnavailableUnavailableNone listed
< 2.39.4affectedUnavailableUnavailableUnavailableNone listed