CVE-2024-32655
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2024
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
Npgsql Vulnerable to SQL Injection via Protocol Message Size Overflow
Npgsql is the .NET data provider for PostgreSQL. The `WriteBind()` method in `src/Npgsql/Internal/NpgsqlConnector.FrontendMessages.cs` uses `int` variables to store the message length and the sum of parameter lengths. Both variables overflow when the sum of parameter lengths becomes too large. This causes Npgsql to write a message size that is too small when constructing a Postgres protocol message to send it over the network to the database. When parsing the message, the database will only read a small number of bytes and treat any following bytes as new messages while they belong to the old message. Attackers can abuse this to inject arbitrary Postgres protocol messages into the connection, leading to the execution of arbitrary SQL statements on the application's behalf. This vulnerability is fixed in 4.0.14, 4.1.13, 5.0.18, 6.0.11, 7.0.7, and 8.0.3.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
npgsql
- Vendor
- npgsql
- Product
- npgsql
- Platforms
- Unknown
- Default status
Unknown
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| >= 4.0.0, < 4.0.14 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 4.1.0, < 4.1.13 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 5.0.0, < 5.0.18 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 6.0.0, < 6.0.11 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 7.0.0, < 7.0.7 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 8.0.0, < 8.0.3 | affected | Unavailable | Unavailable | Unavailable | None listed |