cveboard RSS feed

CVE-2024-41964

CVE.org · Published

Historical CVEsJSONAI instructions

Record status
Published
Identifier year (not publication year)
2024
Source publication
Source updated
Imported by cveboard
Source snapshot
cve_2026-10-24_midnight_baseline ·

Plain text

CNA source text (English)

Insufficient permission checks in the language settings in Kirby CMS

Kirby is a CMS targeting designers and editors. Kirby allows to restrict the permissions of specific user roles. Users of that role can only perform permitted actions. Permissions for creating and deleting languages have already existed and could be configured, but were not enforced by Kirby's frontend or backend code. A permission for updating existing languages has not existed before the patched versions. So disabling the languages.* wildcard permission for a role could not have prohibited updates to existing language definitions. The missing permission checks allowed attackers with Panel access to manipulate the language definitions. The problem has been patched in Kirby 3.6.6.6, Kirby 3.7.5.5, Kirby 3.8.4.4, Kirby 3.9.8.2, Kirby 3.10.1.1, and Kirby 4.3.1. Please update to one of these or a later version to fix the vulnerability. There are no known workarounds for this vulnerability.

Scoped product and version facts

Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.

Exploitation unknown; this catalogue does not assess exploitation.

kirby

Vendor
getkirby
Product
kirby
Platforms
Unknown
Default status
Unknown
kirby · Scoped product and version facts
Version (version)Status (status)Version scheme (versionType)Exclusive end (lessThan)Inclusive end (lessThanOrEqual)Status changes (at → status)
< 3.6.6.6affectedUnavailableUnavailableUnavailableNone listed
>= 3.7.0, < 3.7.5.5affectedUnavailableUnavailableUnavailableNone listed
>= 3.8.0, < 3.8.4.4affectedUnavailableUnavailableUnavailableNone listed
>= 3.9.0, < 3.9.8.2affectedUnavailableUnavailableUnavailableNone listed
>= 3.10.0, < 3.10.1.1affectedUnavailableUnavailableUnavailableNone listed
>= 4.0.0, < 4.3.1affectedUnavailableUnavailableUnavailableNone listed