{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2024-42501",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2024-42501",
    "idYear": 2024,
    "status": "PUBLISHED",
    "publishedAt": "2024-09-17T17:13:34.722Z",
    "updatedAt": "2024-09-18T14:58:56.294Z",
    "importedAt": "2026-10-24T01:57:16.009Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Authenticated Path Traversal Vulnerability Leads to a Remote Command Execution (RCE)",
      "summary": "An authenticated Path Traversal vulnerabilities exists in the ArubaOS. Successful exploitation of this vulnerability allows an attacker to install unsigned packages on the underlying operating system, enabling the threat actor to execute arbitrary code or install implants.",
      "affected": [
        {
          "vendor": "Hewlett Packard Enterprise (HPE)",
          "product": "Aruba OS",
          "defaultStatus": "affected",
          "versions": [
            {
              "version": "Version 10.6.0.0: 10.6.0.2 and below",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "<=10.6.0.2"
            },
            {
              "version": "Version 8.10.0.0: 8.10.0.13 and below",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "<=8.10.0.13"
            },
            {
              "version": "Version 10.5.0.0: 10.6.0.0 and below",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "<=10.6.0.0"
            },
            {
              "version": "Version 10.3.0.0: 10.4.0.0 and below",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "<=10.4.0.0"
            },
            {
              "version": "Version 8.11.0.0: 8.12.0.0 and below",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "<=8.12.0.0"
            },
            {
              "version": "Version 8.12.0.0: 8.12.0.1 and below",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "<=8.12.0.1"
            },
            {
              "version": "Version 6.5.4.0: 8.9.0.0 and below",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "<=8.9.0.0"
            }
          ]
        }
      ]
    }
  }
}