{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2025-48385",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2025-48385",
    "idYear": 2025,
    "status": "PUBLISHED",
    "publishedAt": "2025-07-08T18:23:44.405Z",
    "updatedAt": "2025-11-04T21:11:01.641Z",
    "importedAt": "2026-10-24T01:57:34.152Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Git alllows arbitrary file writes via bundle-uri parameter injection",
      "summary": "Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload parts of the clone to a CDN. The Git client does not perform sufficient validation of the advertised bundles, which allows the remote side to perform protocol injection. This protocol injection can cause the client to write the fetched bundle to a location controlled by the adversary. The fetched content is fully controlled by the server, which can in the worst case lead to arbitrary code execution. The use of bundle URIs is not enabled by default and can be controlled by the bundle.heuristic config option. Some cases of the vulnerability require that the adversary is in control of where a repository will be cloned to. This either requires social engineering or a recursive clone with submodules. These cases can thus be avoided by disabling recursive clones. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.",
      "affected": [
        {
          "vendor": "git",
          "product": "git",
          "versions": [
            {
              "version": "< 2.43.7",
              "status": "affected"
            },
            {
              "version": ">= 2.44.0-rc0, < 2.44.4",
              "status": "affected"
            },
            {
              "version": ">= 2.45.0-rc0, < 2.45.4",
              "status": "affected"
            },
            {
              "version": ">= 2.46.0-rc0, < 2.46.4",
              "status": "affected"
            },
            {
              "version": ">= 2.47.0-rc0, < 2.47.3",
              "status": "affected"
            },
            {
              "version": ">= 2.48.0-rc0, < 2.48.2",
              "status": "affected"
            },
            {
              "version": ">= 2.49.0-rc0, < 2.49.1",
              "status": "affected"
            },
            {
              "version": ">= 2.50.0-rc0, < 2.50.1",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}