{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2025-53689",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2025-53689",
    "idYear": 2025,
    "status": "PUBLISHED",
    "publishedAt": "2025-07-14T09:15:38.863Z",
    "updatedAt": "2025-11-04T21:12:33.255Z",
    "importedAt": "2026-10-24T01:57:39.058Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons",
      "summary": "Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges.\n\nUsers are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.",
      "affected": [
        {
          "vendor": "Apache Software Foundation",
          "product": "Apache Jackrabbit",
          "packageName": "org.apache.jackrabbit:jackrabbit-spi-commons",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "2.20.0",
              "status": "affected",
              "versionType": "maven",
              "lessThan": "2.20.17"
            },
            {
              "version": "2.22.0",
              "status": "affected",
              "versionType": "maven",
              "lessThan": "2.22.1"
            },
            {
              "version": "2.23.0-beta",
              "status": "affected",
              "versionType": "maven",
              "lessThan": "2.23.2-beta"
            }
          ]
        }
      ]
    }
  }
}