cveboard RSS feed

CVE-2025-69289

CVE.org · Published

Historical CVEsJSONAI instructions

Record status
Published
Identifier year (not publication year)
2025
Source publication
Source updated
Imported by cveboard
Source snapshot
cve_2026-10-24_midnight_baseline ·

Plain text

CNA source text (English)

Discourse has insecure default configuration that allows non-admin moderators to takeover any non-staff account via email change

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

Scoped product and version facts

Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.

Exploitation unknown; this catalogue does not assess exploitation.

discourse

Vendor
discourse
Product
discourse
Platforms
Unknown
Default status
Unknown
discourse · Scoped product and version facts
Version (version)Status (status)Version scheme (versionType)Exclusive end (lessThan)Inclusive end (lessThanOrEqual)Status changes (at → status)
< 3.5.4affectedUnavailableUnavailableUnavailableNone listed
>= 2025.11.0-latest, < 2025.11.2affectedUnavailableUnavailableUnavailableNone listed
>= 2025.12.0-latest, < 2025.12.1affectedUnavailableUnavailableUnavailableNone listed
>= 2026.1.0-latest, < 2026.1.0affectedUnavailableUnavailableUnavailableNone listed