{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2025-8259",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2025-8259",
    "idYear": 2025,
    "status": "PUBLISHED",
    "publishedAt": "2025-07-28T05:32:04.923Z",
    "updatedAt": "2026-04-15T07:08:25.330Z",
    "importedAt": "2026-10-24T01:57:44.935Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Vaelsys VaelsysV4 Web interface vgrid_server.php execute_DataObjectProc os command injection",
      "summary": "A vulnerability was identified in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. Affected by this issue is the function execute_DataObjectProc of the file /grid/vgrid_server.php of the component Web interface. Such manipulation of the argument xajaxargs leads to os command injection. The attack can be executed remotely. The exploit is publicly available and might be used. Upgrading to version 5.1.1 and 5.4.1 can resolve this issue. It is suggested to upgrade the affected component.",
      "affected": [
        {
          "vendor": "Vaelsys",
          "product": "VaelsysV4",
          "versions": [
            {
              "version": "5.0",
              "status": "affected"
            },
            {
              "version": "5.1",
              "status": "affected"
            },
            {
              "version": "5.1.0",
              "status": "affected"
            },
            {
              "version": "5.2",
              "status": "affected"
            },
            {
              "version": "5.3",
              "status": "affected"
            },
            {
              "version": "5.4.0",
              "status": "affected"
            },
            {
              "version": "5.1.1",
              "status": "unaffected"
            },
            {
              "version": "5.4.1",
              "status": "unaffected"
            }
          ]
        }
      ]
    }
  }
}