{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2026-101296",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2026-101296",
    "idYear": 2026,
    "status": "PUBLISHED",
    "publishedAt": "2026-10-20T13:45:39.959Z",
    "updatedAt": "2026-10-21T06:31:55.233Z",
    "importedAt": "2026-10-24T01:57:50.502Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Apache Tomcat: JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms",
      "summary": "A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password.\n\n\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122.\n\n\n\nThe following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.\n\n\n\nUsers are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.",
      "affected": [
        {
          "vendor": "Apache Software Foundation",
          "product": "Apache Tomcat",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "11.0.0-M1",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "11.0.26"
            },
            {
              "version": "10.1.0-M1",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "10.1.60"
            },
            {
              "version": "9.0.0.M1",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "9.0.122"
            },
            {
              "version": "8.5.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "8.5.100"
            },
            {
              "version": "7.0.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "7.0.109"
            }
          ]
        }
      ]
    }
  }
}