{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2026-103241",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2026-103241",
    "idYear": 2026,
    "status": "PUBLISHED",
    "publishedAt": "2026-09-30T16:45:13.581Z",
    "updatedAt": "2026-10-02T16:23:50.737Z",
    "importedAt": "2026-10-24T01:57:50.502Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "vllm-project vLLM Gemma4UnifiedParser gemma4.rs denial of service",
      "summary": "A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.",
      "affected": [
        {
          "vendor": "vllm-project",
          "product": "vLLM",
          "versions": [
            {
              "version": "0.1",
              "status": "affected"
            },
            {
              "version": "0.2",
              "status": "affected"
            },
            {
              "version": "0.3",
              "status": "affected"
            },
            {
              "version": "0.4",
              "status": "affected"
            },
            {
              "version": "0.5",
              "status": "affected"
            },
            {
              "version": "0.6",
              "status": "affected"
            },
            {
              "version": "0.7",
              "status": "affected"
            },
            {
              "version": "0.8",
              "status": "affected"
            },
            {
              "version": "0.9",
              "status": "affected"
            },
            {
              "version": "0.10",
              "status": "affected"
            },
            {
              "version": "0.11",
              "status": "affected"
            },
            {
              "version": "0.12",
              "status": "affected"
            },
            {
              "version": "0.13",
              "status": "affected"
            },
            {
              "version": "0.14",
              "status": "affected"
            },
            {
              "version": "0.15",
              "status": "affected"
            },
            {
              "version": "0.16",
              "status": "affected"
            },
            {
              "version": "0.17",
              "status": "affected"
            },
            {
              "version": "0.18",
              "status": "affected"
            },
            {
              "version": "0.19",
              "status": "affected"
            },
            {
              "version": "0.20",
              "status": "affected"
            },
            {
              "version": "0.21",
              "status": "affected"
            },
            {
              "version": "0.22",
              "status": "affected"
            },
            {
              "version": "0.23",
              "status": "affected"
            },
            {
              "version": "0.24",
              "status": "affected"
            },
            {
              "version": "0.25",
              "status": "affected"
            },
            {
              "version": "0.26.0",
              "status": "affected"
            },
            {
              "version": "0.29.1rc0",
              "status": "unaffected"
            }
          ]
        }
      ]
    }
  }
}