{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2026-11440",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2026-11440",
    "idYear": 2026,
    "status": "PUBLISHED",
    "publishedAt": "2026-06-06T17:30:11.510Z",
    "updatedAt": "2026-06-08T16:30:48.196Z",
    "importedAt": "2026-10-24T01:57:50.502Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "theonedev REST API default-branch improper authorization",
      "summary": "A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.",
      "affected": [
        {
          "vendor": "theonedev",
          "product": "onedev",
          "versions": [
            {
              "version": "15.0.0",
              "status": "affected"
            },
            {
              "version": "15.0.1",
              "status": "affected"
            },
            {
              "version": "15.0.2",
              "status": "affected"
            },
            {
              "version": "15.0.3",
              "status": "affected"
            },
            {
              "version": "15.0.4",
              "status": "affected"
            },
            {
              "version": "15.0.5",
              "status": "affected"
            },
            {
              "version": "15.0.6",
              "status": "unaffected"
            }
          ]
        }
      ]
    }
  }
}