CVE-2026-43515
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2026
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
Apache Tomcat: Security constraints not correctly applied
Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
Apache Tomcat
- Vendor
- Apache Software Foundation
- Product
- Apache Tomcat
- Platforms
- Unknown
- Default status
unaffected
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| 11.0.0-M1 | affected | semver | Unavailable | 11.0.21 | None listed |
| 10.1.0-M1 | affected | semver | Unavailable | 10.1.54 | None listed |
| 9.0.0.M1 | affected | semver | Unavailable | 9.0.117 | None listed |
| 8.5.0 | affected | semver | Unavailable | 8.5.100 | None listed |
| 7.0.0 | affected | semver | Unavailable | 7.0.109 | None listed |
| 0 | unknown | semver | 7.0.0 | Unavailable | None listed |