{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2026-44728",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2026-44728",
    "idYear": 2026,
    "status": "PUBLISHED",
    "publishedAt": "2026-05-26T17:48:57.603Z",
    "updatedAt": "2026-05-28T03:55:38.825Z",
    "importedAt": "2026-10-24T01:58:14.884Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Improper Control of Generation of Code when compiling specifically crafted malicious code with @babel/plugin-transform-modules-systemjs",
      "summary": "Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.",
      "affected": [
        {
          "vendor": "babel",
          "product": "babel",
          "versions": [
            {
              "version": ">= 7.12.0, < 7.29.4",
              "status": "affected"
            },
            {
              "version": ">= 8.0.0-alpha.0, < 8.0.0-alpha.13",
              "status": "affected"
            }
          ]
        },
        {
          "vendor": "@babel",
          "product": "plugin-transform-modules-systemjs",
          "versions": [
            {
              "version": ">= 7.12.0, < 7.29.4",
              "status": "affected"
            },
            {
              "version": ">= 8.0.0-alpha.0, < 8.0.0-alpha.13",
              "status": "affected"
            }
          ]
        }
      ]
    }
  }
}