{
  "schemaVersion": 1,
  "attribution": [
    {
      "source": "CISA Known Exploited Vulnerabilities",
      "url": "https://www.cisa.gov/known-exploited-vulnerabilities-catalog",
      "licence": "US government work"
    },
    {
      "source": "GitHub Advisory Database",
      "url": "https://github.com/advisories",
      "licence": "CC BY 4.0"
    },
    {
      "source": "Have I Been Pwned",
      "url": "https://haveibeenpwned.com/",
      "licence": "CC BY 4.0"
    },
    {
      "source": "CVE Program (CVE records)",
      "url": "https://www.cve.org/Legal/TermsOfUse",
      "licence": "CVE Terms of Use",
      "notice": "Copyright © 1999-2026, The MITRE Corporation. CVE is a trademark and the CVE logo is a registered trademark of The MITRE Corporation.",
      "terms": "CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE™). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy."
    },
    {
      "source": "FIRST EPSS",
      "url": "https://www.first.org/epss/",
      "licence": "free to use; FIRST requests attribution"
    }
  ],
  "record": {
    "id": "CVE-2026-55957",
    "sourceURL": "https://www.cve.org/CVERecord?id=CVE-2026-55957",
    "idYear": 2026,
    "status": "PUBLISHED",
    "publishedAt": "2026-06-29T20:47:12.661Z",
    "updatedAt": "2026-06-30T13:27:37.064Z",
    "importedAt": "2026-10-24T01:58:20.586Z",
    "snapshot": {
      "id": "cve_2026-10-24_midnight_baseline",
      "at": "2026-10-24T00:00:00.000Z",
      "source": "https://github.com/CVEProject/cvelistV5/releases/tag/cve_2026-10-24_0100Z"
    },
    "facts": {
      "title": "Apache Tomcat: Authentication bypass with JNDIRealm and GSSAPI authenticated bind",
      "summary": "Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.\n\nUsers are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.",
      "affected": [
        {
          "vendor": "Apache Software Foundation",
          "product": "Apache Tomcat",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "11.0.0-M1",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "11.0.4"
            },
            {
              "version": "10.1.0-M1",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "10.1.36"
            },
            {
              "version": "9.0.0.M1",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "9.0.100"
            },
            {
              "version": "8.5.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "8.5.100"
            },
            {
              "version": "7.0.0",
              "status": "affected",
              "versionType": "semver",
              "lessThanOrEqual": "7.0.109"
            },
            {
              "version": "0",
              "status": "unknown",
              "versionType": "semver",
              "lessThan": "7.0.0"
            }
          ]
        }
      ]
    }
  }
}