cveboard Feed RSS

CVE-2023-49295

CVE.org · Publicado

Histórico de CVEsJSONInstruções para IA

Status do registro
Publicado
Ano do identificador (não é o ano de publicação)
2023
Publicação na fonte
Atualização na fonte
Importado pelo cveboard
Snapshot da fonte
cve_2026-10-24_midnight_baseline ·

Texto simples

Texto da CNA em inglês

quic-go's path validation mechanism can cause denial of service

quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.

Fatos de produtos e versões por escopo

Dados de correção desconhecidos; nenhuma versão corrigida é deduzida aqui. Dados ausentes não comprovam ausência de correção.

Exploração desconhecida; este catálogo não avalia exploração.

quic-go

Fornecedor
quic-go
Produto
quic-go
Plataformas
Desconhecido
Status padrão
Desconhecido
quic-go · Fatos de produtos e versões por escopo
Versão (version)Status (status)Esquema de versões (versionType)Fim exclusivo (lessThan)Fim inclusivo (lessThanOrEqual)Mudanças de status (at → status)
= 0.40.0affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 0.39.0, < 0.39.4affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 0.38.0, < 0.38.2affectedIndisponívelIndisponívelIndisponívelNenhuma listada
< 0.37.7affectedIndisponívelIndisponívelIndisponívelNenhuma listada