cveboard Feed RSS

CVE-2024-32463

CVE.org · Publicado

Histórico de CVEsJSONInstruções para IA

Status do registro
Publicado
Ano do identificador (não é o ano de publicação)
2024
Publicação na fonte
Atualização na fonte
Importado pelo cveboard
Snapshot da fonte
cve_2026-10-24_midnight_baseline ·

Texto simples

Texto da CNA em inglês

phlex makes Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags

phlex is an open source framework for building object-oriented views in Ruby. There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. The filter to detect and prevent the use of the `javascript:` URL scheme in the `href` attribute of an `<a>` tag could be bypassed with tab `\t` or newline `\n` characters between the characters of the protocol, e.g. `java\tscript:`. This vulnerability is fixed in 1.10.1, 1.9.2, 1.8.3, 1.7.2, 1.6.3, 1.5.3, and 1.4.2. Configuring a Content Security Policy that does not allow `unsafe-inline` would effectively prevent this vulnerability from being exploited.

Fatos de produtos e versões por escopo

Dados de correção desconhecidos; nenhuma versão corrigida é deduzida aqui. Dados ausentes não comprovam ausência de correção.

Exploração desconhecida; este catálogo não avalia exploração.

phlex

Fornecedor
phlex-ruby
Produto
phlex
Plataformas
Desconhecido
Status padrão
Desconhecido
phlex · Fatos de produtos e versões por escopo
Versão (version)Status (status)Esquema de versões (versionType)Fim exclusivo (lessThan)Fim inclusivo (lessThanOrEqual)Mudanças de status (at → status)
>= 1.10.0, < 1.10.1affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 1.9.0, < 1.9.2affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 1.8.0, < 1.8.3affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 1.7.0, < 1.7.2affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 1.6.0, < 1.6.3affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 1.5.0, < 1.5.3affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 1.4.0, < 1.4.2affectedIndisponívelIndisponívelIndisponívelNenhuma listada