cveboard Feed RSS

CVE-2026-53495

CVE.org · Publicado

Histórico de CVEsJSONInstruções para IA

Status do registro
Publicado
Ano do identificador (não é o ano de publicação)
2026
Publicação na fonte
Atualização na fonte
Importado pelo cveboard
Snapshot da fonte
cve_2026-10-24_midnight_baseline ·

Texto simples

Texto da CNA em inglês

containerd CRI ExecSync Goroutine Leak Leading to Node-Level Denial of Service

containerd is an open-source container runtime. Prior to 1.7.35, 2.0.12, 2.2.8, and 2.3.5, containerd on Linux with the CRI plugin enabled can indefinitely block the drainExecSyncIO goroutine in internal/cri/server/container_execsync.go when CRI ExecSync is used by exec probes or lifecycle hooks that launch long-lived background child processes retaining standard input and output pipes. The input and output drain phase has no default timeout and did not stop when the request context was canceled, so repeated ExecSync invocations can accumulate blocked goroutines and host memory. The resulting resource exhaustion can cause the OOM killer to terminate containerd, leaving the container runtime unavailable until restart. Deployments not using containerd's CRI implementation and containers not running on Linux are not affected. This issue is fixed in versions 1.7.35, 2.0.12, 2.2.8, and 2.3.5.

Fatos de produtos e versões por escopo

Dados de correção desconhecidos; nenhuma versão corrigida é deduzida aqui. Dados ausentes não comprovam ausência de correção.

Exploração desconhecida; este catálogo não avalia exploração.

containerd

Fornecedor
containerd
Produto
containerd
Plataformas
Desconhecido
Status padrão
Desconhecido
containerd · Fatos de produtos e versões por escopo
Versão (version)Status (status)Esquema de versões (versionType)Fim exclusivo (lessThan)Fim inclusivo (lessThanOrEqual)Mudanças de status (at → status)
< 1.7.35affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 2.0.0, < 2.0.12affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 2.2.0, < 2.2.8affectedIndisponívelIndisponívelIndisponívelNenhuma listada
>= 2.3.0, < 2.3.5affectedIndisponívelIndisponívelIndisponívelNenhuma listada