CVE-2017-15708
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2017
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
Apache Synapse
- Vendor
- Apache Software Foundation
- Product
- Apache Synapse
- Platforms
- Unknown
- Default status
Unknown
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| 3.0.0 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 2.1.0 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 2.0.0 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 1.2 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 1.1.2 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 1.1.1 | affected | Unavailable | Unavailable | Unavailable | None listed |